Software Beta release

Works for me:

Might it be that your window is too small and you need to scroll the tab bar?

It is there now. I had shut down and restarted in between as I needed to move the microscope, I don’t know if that made a difference. It was not a scroll problem as the window is large and the layout adjusts to have the about at the bottom as long as there is room to fit all the buttons.

Probably just a freak occurrence then.

Thank you,
I just tested it.
Are we supposed to be able to toggle between this 2 options?
image
Currently I can disable it but I can’t enable it again unless I repeat the auto calibration.

PS: will there be a time course option in the capture menu?

Hmm, that looks like it’s still the old interface. If you have definitely updated, you might need to refresh or “force reload” the interface. The calibration buttons should now look like this:


If you click the “about” tab, does the “server version” report as 2.10.0b1?

If you are using OpenFlexure Connect, you can force refresh as shown:
image

There isn’t currently a way to toggle the flat-field correction on and off without re-calibrating. That would be a useful feature, but it would require a change to the way we handle camera settings. If you felt like requesting that feature by raising an issue on the openflexure-microscope-server repository on gitlab, that will ensure we don’t forget about it!

Thank you, after doing force reload I have

Server version: 2.10.0b1

and I have the new calibration interface.

It’s just that I wasn’t sure if it was meant to toggle or not. Is there a documentation for the software describing how each calibration is done, how the stitching is done, etc…? What does Store raw data do (in capture menu)?

Other questions I have are for example whether the auto gain & shutter speed should be performed with or without a sample (idem for the other calibrations).

Also, when I use the set path button in the storage menu nothing seems to happen…am I supposed to be able to create subfolders ?
image

Maybe a button reset to defaults settings would be useful in the Camera settings menu.
(and a time course option :face_with_hand_over_mouth:)

Also I can confirm that the 8GB model not supported seems to work fine
image
(screenshot from this page)

Thank you very much!
I started using the openflexure microscope yesterday and I amazed by the whole microscope and software :star_struck:

1 Like

Thanks for that, that’s all useful - with the 8Gb Pi, are you running 32 or 64-bit OS? I think the problem is that if you run the 32-bit OS, it might not use the full 8Gb of RAM. So you may not get any advantage over a 4Gb model. However, it is nice to know that it works!

There’s documentation about the internals of the server, the HTTP API, and how to write plugins. However, there’s not really much of a user manual! We should really sort that out… Currently, stitching isn’t done by the OpenFlexure software, but I think folk in the forum have described how they have stitched images with ImageJ. Maybe start a thread about that if you can’t find more info, and mention @dgrosen because he’s made some stunning stitched images!

“store raw data” means that the JPEG image also embeds the raw data - though you currently need to use a different tool to extract it; the gallery only shows the processed JPEG image, even if raw data is present.

Auto gain and shutter speed should work either with or without a sample - and should be fine to re-run whenever the image looks too bright or too dark.

The “set path” button just allows you to choose from locations in the menu above; it’s really only there to allow you to switch between the Raspberry Pi’s SD card, and external USB storage (if you plug in a USB stick, the autostorage extension should make it easy for you to save images there, instead of the SD card). We should definitely make this clearer when we write a software manual…

1 Like

A button to reset the camera settings would be useful, I think - though it would probably also need to restart the microscope to work properly. I am fairly sure there is a timelapse function in a demo extension somewhere, we should probably enable this by default, though!

1 Like

Auto gain & shutter speed is useful with the sample in place, if you have a dark sample or something. It retains the white balance and the even brightness across the picture, but adjusts the brightness so that you can see the sample. The other auto ... are calibration and must be done without a sample. They aim to make the whole image flat white.

As rightly pointed out by @William the autocalibration has improved a lot…I used to see dark pink areas directly under the light source because of not using the condenser lens…however with this update I don’t even require a condenser lens.

But the autofocus ability has gone down when performing stack n scan. Its capturing blurry images mixed with focused images in both the sequences.

Also If some help tab be provided for the different types of scan(spiral, raster and snake)- Like where to start on the slide, Placement of slide on the stage and in which direction the scan is performed ?..it would be really helpful.

I’m surprised to hear the autofocus is less reliable; I can’t think of any code changes that should affect that! Do you mean the “fast” autofocus, or one of the older coarse/medium/fine versions? The fast autofocus method is quite sensitive to timing, but I just can’t think of anything that has changed between the beta and the last release. We have upgraded numpy to 1.20, and a few other dependencies, but none of them ought to have changed anything…

It’s the fast one I suppose which comes into action during stack n scan.Scan parameters are as follows.
Step number-15 15 1
Step size- 2000 2000 50
Spiral
Does it have anything to do with the Z step no which I set as one ,because I wanted the scan to complete quickly and previous auto focus was quite good …and I wanted less no of pics for stitching.

EDIT: I had mistakenly run the forced reset in the “OpenFlexure Connect” window not the “Microscope” window. The new features show correctly now. Thanks!

I’ve updated as per the instructions including the forced reset. I’m showing Server version 2.10.0b1 however I’m not getting the new features. Any suggestions?

1 Like

I guess the trouble with assessing autofocus reliability is that unless you go to some serious lengths to collect statistics, it’s quite hard to really know if it’s become better or worse… @JohemianKnapsody has been working on improving the fast autofocus (especially if you want to acquire a Z stack) but that will take a little while to make it into a beta release, and is currently only tuned for using a 100x lens.

Setting the number of Z steps to 1 will disable Z stacking, but should have no effect on the autofocus routine. If the number of Z steps is 1, the Z step size is ignored.

You’re right, it would be good to document the scan paths somewhere. Again, @JohemianKnapsody did a nice job of visualising scans, so we should figure out how to integrate that into the GUI in a future release. In the meantime, we really ought to start some sort of software manual…

The Spiral scan is not finishing even after the task indicator completely fills the bar.New images are being captured continously.I had to manually cancel the task.

The number of steps as can be noted was 10 10 1…but the number of captures has gone beyond 200 …

thanks - that’s one I should look into! Did the abort button work? If so, that’s progress at least…

If you’re able to raise an issue I’ll do my best to fix that one.

Yes I could cancel the task…I ll try to raise the issue

One more thing I would like to ask w.r.t scan…should the z step size be increased proportional(some sort of) to the x and y step size …to accommodate the deviations/errors?..so that autofocus doesn’t stray beyond certain steps?

The Z step size in the scan refers to the spacing between images in a Z stack at each XY location; it’s separate from the range of the autofocus. In general, you’re right - the potential for focus drift between images increases as the step size gets bigger. However, if you are using the “fast” autofocus method, its default range is quite large anyway so I would be surprised if this was a problem.


Another stack n scan issue
Capture button becomes non responsive if resolution of image is not selected either as full or resize… cannot terminate the event too.