Cannot calibrate microscope, gui missing and no wizzard

Hey all, I’ve just built my first openflexure microscope. I used the alternative electronics guide to build a sangaboard out of an Arduino Nano Every. I’m using a Raspberry Pi 4 with a pi camera 2 and a 40x RMS objective.

When I boot up Connect on the pi (or remotely) I get the tour guide but there’s no calibration wizard. I can move the microscope in XYZ using the controls and can see the image so it seems all the hardware is discovered, but there’s no calibration options in the settings menu.

I’ve checked the logs, status, and tried ofm reset, ofm upgrade, upgrade --pre, ofm update. None of these makes calibration appear.

Looking in the log the only warning I can see is something like L??_MANIFEST missing in the file in the extension directory (apologies I’m away from the microscope today so cannot give the exact error).

Can anyone suggest what to try next?

I noted the documentation says it’s not compatible with a pi 4 8gb, not sure if I have one of those, will check.
I’ll also try reflashing the pi again for a fresh start.

Welcome @toastedcrumpets. Reflashing the Pi is often the solution in these cases unfortunately. I don’t think it would be because of using an 8GB Pi, people have tested those and they do work but may not be able to use all 8GB.
If you have the web app running then you can find the calibration without it coming up automatically. it is under settings and camera I think. I also have not got my microscope at this desk.

Thanks for the response!
Yes I can see the section for calibration in the settings but there’s no controls visible there. I used developer tools to see if they were just hidden but there was nothing (and the JavaScript console had no errors).

I’ll try a reflash when I get home and update!

Sure enough, a clean reinstall fixed it!

The only difference was that I rejected an update of the system this time.

Anyway, thank you for an amazing project!


That’s strange - I have not seen that before. If you still have the old SD card, could you post a screenshot when you next have the chance? Something must have broken, but I can’t think what might have broken that would have produced that effect!

Hi Richard, first, thank you for the project! I’ve now built the delta stage too and its all such a great project, so thank you for developing this openly.

Unfortunately I wiped the original SD card to reinstall, so I’ve lost the chance to get more debugging info for you.

I can say that I first started the software with a local connection, and the GPU/direct preview is on by default, so I didn’t manage to see the “tour” or any other onboarding flow. It took me some almost accidental movement of the window during a later boot to see there was a tour underneath. My guess is that I may have closed the window at some unexpected point in the initial setup leaving a partially configured state?

I would humbly suggest that the GPU preview is off by default, i found the software much easier to use once I disabled this as a first time user.

1 Like

Hi @toastedcrumpets thanks - I agree the GPU preview should be of by default, it was very important for usability with old raspberry pi computers but now it’s a headache. The next software version will take a while but this change should be in there.

Even if it was partially configured, I am still mystified that the calibration controls were gone - they are all in one statically included JavaScript bundle along with the rest of the web app…