Settings not being saved

I’ve built my microscope and all seems fine. However, when I attempt autocalibration in the Settings menu, I can an error that reads something like:

[Err_no 13] Permission denied: /var/openflexure/settings/microscope_settings.json

Therefore I don’t think the calibration or other settings are being saved as I don’t have write permission. I read in the manual that this settings file should be in ~/.openflexure/ but this folder doesn’t exist. Is there something I can do to resolve this?


Sorry about that. Which version of OpenFlexure Raspian are you using?

Hi Julian, how do I find the OpenFluxure Raspbian version? I looked at /etc/os_release but that just told me that I was using buster.
Thanks, Andy

Hmm, that is a good question… Do you have the zip file you downloaded? That should start with the date. If not @jc2450 is the one who will know. We need to get better and not bugging Joel though as he has move onto a new job.

Unfortunately I did some housekeeping over Xmas and deleted everything in the Downloads folder on my laptop. Perhaps it’s best if I get the latest version of OF-Raspbian and install a clean image. I’ll let you know how this goes.
Cheers, Andy

Note that the Raspbian download link on the Downloads page points to a local address:
I’ve located the right page but this needs fixing when you have a moment!

Thanks, I fixed the website error. Let me know i the latest OF build solves the problem. If not I will have to dig deeper. This is our first week since we lost out main software person, so we will not be as fast as usual

Hi guys!

If you run ofm rescue it will give you a bunch of debug information including some useful version information.

The settings now live in /var/openflexure, and the server should run as the openflexure-ws user which has write permissions for that folder. If you manually try to run the server as the pi user, it will fail to write to that location but SHOULD fall back to a user-specific settings file in ~/openflexure.

Hopefully this gets us a bit closer to a fix!

1 Like

Hi Joel, thanks for the reply.
In the end I decided to download the latest image and overwrite the old OS. Even then I was still having problems running Connect locally (the microscope image was on top of all other windows making it difficult to run calibrations), and it seems to behave better when I connect remotely from a Windows laptop. I successfully ran the calibrations and also ran “ofm rescue” as you suggested. This found no openflexure folder in /home/pi and so created it along with settings files in /home/pi/openflexure/settings. I think everything is now OK but I’ll have another play tomorrow when I tire of doing actual work…Next step is to look at some yeast samples in my haemocytometer and see if I can do automated counts in ImageJ.
Cheers, Andy

1 Like