Live Screen Disappears

Hi OFM Forum!

I’m in a pickle and I hope you can get me out of it. I am teaching a summer class for high school students. As our class project, we have been building OpenFlexure Microscopes. I made kits for all the students. I installed Raspbian-OpenFlexure Lite onto all the MicroSD cards. I even checked to make sure that each Pi boots up and can be accessed remotely. Students have completed assembly and are now trying to connect to and control the microscopes. They are all accessing the Raspberry Pi remotely - either through ethernet or WiFi. To add another layer of complexity, we are doing all of this remotely because the school district still doesn’t want anyone coming onto campus. Each student needs to connect in a different way according to the computer supplies they have available at home.

Students are able to connect to the Pi’s both with WiFi and ethernet. And they are able to access OpenFlexure Connect both with a web browser and by downloading and installing OpenFlexure Connect on their computers. The issue we’re having is that the live view screen in “View”, “Capture” and “Settings - Camera” frequently disappears, leaving behind only a blank screen. Screenshot attached. Sometimes there’s an icon which shows a torn page and the word “Live”. (Don’t have a pic of that.) It seems this may be a connection issue, as the connection seems to drop out but the remote OpenFlexure Connect window stays open. Is this a security settings/firewall/anti-virus issue? I was not having this issue before when I was testing the microscope kits…

Today was the last day we were supposed to work on the microscopes. The final day of class is Thursday and students were supposed to present pictures they took with the microscopes of various objects they selected. I’m deeply concerned we won’t be able to finish the builds in time. I’m hoping you all have some words of wisdom which can help fix the issue and let us finish the class strong. These things are so cool when they work right!

One more thing: one student reported that when they were in the Raspberry Pi command line changing the WiFi settings in raspi-config they got a “low voltage detected” message. Not sure why that would have happened. The power adapters are all of the correct supply voltage.

Thanks for the help!

Just to add some more info. We are using:

  • 2021-06-17-raspbian-openflexure-buster-armhf-lite install zip
  • Raspberry Pi Model 3 B+
  • Pi Camera v2
  • 16GB Gigastone MicroSD HC card

Saw another post about “Camera feed going white” which seems to be a similar/the same issue? The live screen/connection cut-out issue does seem to occur more frequently when a sample is moved around in the view.

Another issue which may be related is that “Auto-calibrate” takes so long it actually doesn’t finish. One student reported that it worked, but only after 15 minutes of waiting.

Hope that helps diagnostics.

This is a cool project.
The Camera feed going white - Request Help - OpenFlexure Forum does have the same symptoms as yours. There is a solution on that thread post 49 onwards.

OK @WilliamW The fix on that thread seems to work. Thanks for the help. I do still have two separate issues for which I will create new threads.