Camera feed going white

I am running a raspberry PI 3 and am having trouble where the camera feed goes white not long after starting the client, picture shown below. I am moving the sample glass around in front of the camera when this happens. Updates are being shown to the screen up to the point it goes white.
image

Any suggestions on what I should be looking at to solve this? Perhaps related to this, the ofm tool doesn’t seem to do anything when I run any of the sub commands. This is the recently downloaded raspberry pi image available here:
https://build.openflexure.org/raspbian-openflexure/latest

I am viewing via a HDMI connections to the raspberry pi. Perhaps that is not how users normally connect and that is pushing it over the edge for resources.

Thanks

I am watching atop and it looks like the moment the picture goes white is when the system starts paging out to disk. The only thing I am doing is moving the sample slide around on the microscope. I am guessing there is some image processing happening like autofocus that can’t keep up with the rate of change. I am hoping someone can confirm that this is consistent with that is expected. I have a Pi4 on order to arrive tomorrow and am hoping that will resolve this.

Hello!
I had a problem, somewhat different - the image rich in details disappeared when manually focusing (at that time I had no motors connected) Moving and stoping the slide did not cause problems until there was a sharpness, as soon as the focus (or close to it) was set, the image disappeared as soon as mevement stopped

Thanks for adding your experience. I have continued investigating this and suspect it is due to the higher resolution of the Pi camera v2. I see the resolution of the camera included in a openflexure_settings.json file, but not sure if I can update it to maybe 1/4 resolution.
I was also clued in to resolution being involved because when I connect from a remote computer, the network connection maxes out while previewing the images.
I would like to reduce the frequency of images being sampled to reduce the I/O rate being processed.

Hey, could you please try updating to the latest software version to check if it helps at all? We’ve changed how the camera stream thread works internally, so it might help a bit.

From your microscope Pi, please run:

ofm update 
ofm upgrade

I am using a Pi 4 now, so I can’t test that easily.

Thank you

Did this solve the problem?

I have not tried again on a Pi3.