Connection problem with OpenFlexure Connect using Sangaboard v0.5.4

I just finished the assembly of the high resolution microscope (v7). After mounting the hardware, I assembled the electronic components as shown in the assembly tutorial (Assembly Instructions). As I’m using a sangaboard v0.5.4, which should come pre programmed, I directly tried to connect the microscope via ethernet to my laptop, after writing the Raspbian-OpenFlexure on the SD card of the Pi (I tried both versions). The microscope doesn’t show up in the nearby devices in Openflexure Connect and I don’t know how to troubleshoot this, did someone run into a similar issue or am I missing some steps required before the connection? Thanks

1 Like

Hiya! No doubt someone more experienced with Connect will jump in with everything I’ve missed, but I’ve gathered notes on forcing microscopes to make themselves known… the Sangaboard shouldn’t be causing connection issues as Sanga issues usually just make Connect complain that it can’t find the stage.

My usual troubleshooting/diagnostic checklist for an absent microscope starts as follows to eliminate the easiest issues (with apologies if anything sounds too condescending; I write this as they’re usually the fastest things to check!) Assuming you have a fully assembled microscope with Sangaboard atop a Raspberry Pi, everything’s powered from a USB-C port on the Pi, and you have an illumination LED plugged into the Sangaboard:

  1. when plugged in, are you getting any kind of LED lights showing on the Raspberry Pi board to show it’s alive and receiving power? You should see red and green; red typically shows power and green shows activity. From memory, solid red and blinky green is good; anything else might mean that either your microSD card has corrupted firmware on it or your Pi isn’t being powered properly.

  2. Are there blinky lights on the Ethernet port of the Pi? No lights, no communication. I’ve been defeated before by both a dud Ethernet cable and a silently broken USB port with Ethernet dongle.

  3. (assuming you have the full version of Raspbian-Openflexure written on the SD card and not the lite version without desktop!) My usual check that everything’s physically OK on the microscope end is to operate it on its own by connecting it via HDMI to a monitor, USB keyboard and mouse; it should be able to connect to itself through the GUI that way and you can see whether it’s operating as expected.

If none of the above helps, I tend to try a fresh microSD card with a new write of OpenFlexure-Raspbian from Raspberry Pi Imager. I’ve occasionally had bad luck with dodgy MicroSD cards.

If you know the IP address of your microscope (which is unlikely if you’ve never connected, but good to take a note of if you’re using a microscope often!) you can try using the command line to SSH into pi@[IP] or pi@microscope.local to see if it can be found at all. I’ve also noticed that microscopes can also occasionally take a minute to show up on Connect if it’s their first boot.


This does indeed sound like it’s likely not Sangaboard related but a more general problem, but just to confirm can you check what the LED state is of the LED’s on the Sangaboard? Alternatively, if you plug the Sangaboard to a computer using the USB-C what’s the state of the LEDs and does it register as a USB storage?

1 Like