Message error after verifying Sangaboard program with Arduino IDE 2.3.2

Hello to the OFM community,
Thank you very much for sharing the OFM. I’ve finished the hardware part of the OFM, but I’m now having a problem with the Sangaboard program. I downloaded it from Github and opened it in Arduino IDE. When I checked the program with Arduino IDE’s Verify, I got this message:

error : ‘void Stepper::stepMotor(int)’ is private within this context
motors[motor]->stepMotor(8) ;
I’m not familiar with python and I don’t know what’s wrong.
Thank your help,

error: ‘void Stepper::stepMotor(int)’ is private within this context
I’m not familiar with python and I don’t what it is wrong.

What Sangaboard are you using? Is this the Nano-workaround?
To program a Nano from the Arduino IDE, you need all three of the files from the repository: StepperF_alt.cpp, StepperF_alt.h and sangaboard.ino. These need to be in the same directory when you open the .ino file so that the Arduino IDE can find the correct stepper files. Then it should just work. I have never tried the verify function directly.

Hello WilliamW,
You are right. I didn’t pay attention to the fact that the two libraries were placed in different directories of sangaboard.ino.
To answer your questions, OFM controls engines without Sangaboard V0.X. However, in the near future, I will probably update OFM with a Sangaboard. As far as the Arduino nano is concerned, I tried it and was careful to buy a real Arduino nano.