Instructions for uploading sketch to Arduino Nano

Hello I just added this question as a reply to someone else’s issue but I wanted to make sure I added this on the correct platform.
I am having a hard time uploading the Sangaboard sketch onto the Arduino Nano with Processor ATMega328P. I have the latest arduino firmware and I am using an Arduino Nano with individual driver boards on a breadboard with a separate 5V power supply for the stepper motors. However, when I upload the Sangaboard sketch onto the Nano I get an error that says “StepperF_alt.h: No such file or directory”. I understand that this is a library that must be included manually in order for the sketch to work. I am on a Mac but I have access to a windows machine. Does anybody know if there is anything I can do?

Hi Carlos, yes I had some trouble with that too in that I had to make sure the header file was named correctly, to be found. I think I had downloaded the files individually, which named them horribly and I needed to rename them.

Taking a look at this today, I think you want to download the files from here:


I unzip the file and navigate to sangaboard-master\arduino_code\sangaboard
Verify that you see the 3 needed files:

Then open the sangaboard.ino file
And load that to your nano.

If these are the steps you followed already, can you show what you see in your sangaboard/ folder?


Hello Vince,
thank you for the reply. I followed these steps and for some reason the sketch won’t upload to the Arduino Nano. I have two Arduino Nanos and I have tried them on both and I get the same result. The sketch starts uploading and it just gets stuck uploading. I have tried uploading a simpler sketch like the Blink LED example and it works just fine but when I tried the Sangaboard one it just doesn’t.
I have included the screenshot of the Sangaboard folder.

ok, I just tried it again to be sure I wasn’t missing something and it still works for me. Although the problem seems like the Arduino IDE can’t find the file, let me add some pictures of my specific settings in case it is one of these.
I am using IDE v1.8.13

Setting the device to Nano

And have the programmer set to AVRISP mkII

I suspect it has something to do with opening this file instead of the sangaboard.ino: