Delta stage autofocus with x20 objective lens is not working/z-axis not moving as expected?

Hi guys! We set up the delta stage accordingly and got a x20 objective lens but when we try to autofocus, nothing seems to happen.
Before focusing:

After focusing :

From what it seems, the image has just moved in the y direction rather than staying fixed in the z axis and going up and down. Further testing this, we tried moved in the z-axis in general and found that it would drift in the y-axis. The motors are wired and assembled as mentioned so we’re not sure what else is going on or what can be fixed!!

Thank you in advance!

Does the stage move correctly in x and y? You do need to set the stage geometry to ‘Delta’ in the Microscope interface.

If you are set to Delta and it does not work for z, do you see all three motors moving when you do a series of x and y moves? one of x or y needs all three motors, the other just two. If you see all three motors moving that suggests that the motors are OK. The order of the motors as connected to the Sangaboard should not affect z motion as all three need to move the same amount.

That is exactly what we are seeing when we run the machine (with the y axis using all 3 motors and the x axis only needing two if i remember correctly when testing this morning!). If that means all the motors are working correctly and the order does not matter, what else could be the issue?

Your original post is about autofocus. Have you tried just moving in z, and what happens then?
For x and y the motors move, but does the stage move in the way that you expect? There could be a problem with something broken in an actuator.

Apologies! I wasn’t sure if this was a z-axis issue or an autofocus issue though in hindsight, when I tested the Z axis and found it wasn’t working, I should have labelled as a z-axis issue (which answers your question).

When moving in the x-y, it works perfectly with no issues! With the z axis, it will drift towards the y-axis. This is a newly printed delta stage so I’m not sure it can be something broken but I have a spare printed that I will test this on. If it turns out not be the print itself, what else can I test?

Kind regards,

What should I looking for when rotating in the Z axis?

It is a little hard to tell from a distance. A couple of photos may help.

I think what I would do is to remove the motors and try moving the stage by hand. The Delta geometry is hard to move precisely, but moving by hand you can move more quickly and get a feel for what is happening.
If you rotate each actuator in turn, does its leg move across and back?
With the camera on, if you rotate all three actuator gears by the same amount, does it move up and down in focus?

Hi, so just tested these now!

We figured out that our screws we were using were the issue as we had circular heads instead of hex heads but we fixed that and now our z axis works and we can focus the image by manually changing the z axis but our autofocus still doesnt work. The images below show when before and after we tried to use the auto focus option and how the image focuses when we manually change the z-axis!

Before using autofocus method

After trying autofocus method (with fine, medium and fast)

Manually changing z-axis to focus image

It’s clear to see that the image can be focused but the auto focus option just doesn’t work. Any ideas to why this is happening?

Great to hear that you found the hardware issue.

If you can focus manually using the motor controls, then autofocus should work. Fast Autofocus is most robust, unless your image is small points of light or dark on a plain background (like stars). The range of autofocus is 2000 steps as standard, so it will not find focus from a long way away. When you run the autofocus routines, do you see the motors moving to move the stage vertically, and do you see the image appear to change in how out-of-focus it is? If you focus manually and then move away from focus by, say, 100 steps, does autofocus still not work?