Y axis movement not smooth

When connected all cables, the Y axis does not turn smooth. Instead of the X- and Z axis the motor has now power.
1e tried:
Changed the motors of
the Y axis to the Z board
the Z axis to the Y board.
Also the motor that is contolled by the Y bord has the same problem as above.
2nd tried:
Changed the cables from arduino to controlboard motors
Pins D6 to D9 for Y-axis connected with Z board
Pins D2 to D5 for Z-axis connected with Y board
Motor on Y-axis bord OK
Motor on Z-axis bord NOK, See above .
Is my arduino defect, or could the upload of the code went wrong.
Remark:
When starting the microscoop software,on the X and Z axis bord there is only LED A on, at Y axis board are LEDS A and B on.

Your test 1 seems to show that it is not the Y-axis motor that is at fault. Test 2 suggests that it is not the Y-axis motor control board. The motors and boards are very low cost, so I have heard of them not working properly, but your tests suggest that yours are OK.
That does leave either the arduino or the arduino code. It could also be the jumper cables connecting the arduino to the motor board. It is easy to re-load the code to the arduino, so I would do that. If you have another arduino that would be the next try o think.

Hi William,
Its the same I tought.
I did already reload the code, but it was not succesfull.
Now I will try to make a code for the arduino to lighting a ledlight on ports D6 to D9, to verify the arduino. If this not works I need to by a new arduino board.
Do you know if an clone board works as well as an original arduino?

Hi william,
I think the error is found.
With a simple sketch (led on and off) with a led on pin 6-7-8 and 9 the led on pin 8 always on while the other leds following the loop of 1 second on, 1 second off.
Led on pin 8 constantly on when the nano is connected with the power supply(with USB cable)

That seems convincing. Are there unused digital ports on your arduino on the sketch for the microscope? If you have identified that D8 is faulty, you could move that, or the set of four for that motor, to different unused ports.
On arduino clones, they work well. Some have a different USB to serial converter chip. That used to need some software to make it work. In newer Windows I have found they work by default.

Hi William,
Thanks, I look further, perhaps there are unused pins that can be used instead of pin 8.

Hi William,
I ordered a new nano kloon, an arduino nano V3. The problem is that the raspberry py the board not recognized. Probably a USB to serial problem.
When I started up the Pi with connected nano board, I got some errors, concerning USB ports.
Started the command line and give command “lsusb” it gives no connection to a nano board on a USB port. see attached screenshot

The windows PC its not a problem, the sketch is uploading without an error.
I have done this also with a simple sketch, to lighting some leds on different ports, and it works very well.
What could be the problem?

I have not particularly used Arduino with the Pi. If it works on a PC, but not on the RPi, that sounds like the USB to serial converter needing a different driver, as in post 5. I don’t know the exact fix, but you will probably find it on RPi or Arduino discussions.

Hi William,
Thanks, I look further.