Stream Preview Disabled & 500 Error

We’ve recently come upon a new (to us) issue. We have a microscope that was previously working. We are connecting to it locally, but now when we click “Connect”, we get a message stating “Stream preview disabled”. Occasionally, we will also get an error “500: deque mutated”.

So far, we have tried:

  • Replacing the camera module.
  • Replacing the FFS cable.
  • Replacing the Raspberry Pi (but using the same SD card).
  • Reimaging the SD card with a fresh installation of the OnlyFlexure Raspbian OS.
  • Enabling I2C in Raspi-config, which at least results in a different error: "500: No data recieved from sensor. Check all connections, including the SUNNY chip on the camera board.

We also saw that there’s a an option to “Disable web stream” under Display Settings. That box appears to be checked by default. When we uncheck that box, the preview screen displays a message stating “Camera disconnected”, followed by the clock.

The camera is shown as being supported and detected using “vcgencmd get_camera” in the terminal.

I’m sure there’s probably something obvious we’re overlooking, but I didn’t see anything else on the forum related to this issue. Has anyone encountered it before or have suggestions on how to resolve it?


Is the new camera the original raspberry camera V2?

We’re using the Rasp Pi Camera linked below. It is labeled “V 2.1”

That’s the right one

I ordered a “V 2” camera and installed it. The software works with that.

Two different “V 2.1” cameras that had been previously been working do not work on the same Raspberry Pi that works with the “V 2” camera.

That kind of issue is really hard to diagnose. I don’t think there will be an actual difference between things sold as camera V2 and v2.1, the camera was version 2.1 when launched as far as I know. The board usually says.
Have you got more than one system, and do the other cameras work on that or not? As they worked before it does sound as though they have become damaged in some way.