Restricted actuator movement

Hello everyone,

We in our lab want to utilize the openflexure microscope for experiments. Our goal is to print
several of them to run a lot of experiments in parallel.
To test the microscope we first assembled one to test it. We got some problems with the Nano, but after
switching to the Uno everything works fine now.
Except that the actuator movement is somehow restricted. The movement direction that is caused by pulling up the screw nut works fine and we get the full 6 mm range of motion. The other direction however is restricted. It seems that the O-Ring has not the power to pull down the actuator. Instead, the screw with the gear gets pushed out.

I assume we use the recommended o-rings with inner diameter of 30 mm and a thickness of 2 mm with a hardness of 80.
Link to the o-ring: O-ring 30x2 - FKM - FPM - Viton - 80 Shore A - Black - ORS23647 - O-ring-stocks.eu O-Ring Webshop
Everything was printed with the recommended settings.

So far we do not understand why this is the case. Does anyone here have an idea to solve this issue?

Thanks in advance :slight_smile:

1 Like

Hello.

No solution but I am also experiencing this effect. I get a lot (roughly double) more motion in one direction than the other when I initialise the feet flush with the body so the stage is vertical and centred.

Are you using 5V stepper motors? I have some 12V motors I may try later. I suspect the problem is the initial starting position. There doesn’t seem to be a lot of information regarding the best initial stage position.

Im still trying to figure it all out but it appears there are two separate limits. In one direction the limit is the length of the bolt as it screws completely out of the nut. The opposite limit appears to be structural or limited by the stepper power or breaking something!

I would be interested to know how others zero the stage.

Thanks.

We use 5V stepper motors. The zero position is when only the nut is visible.
We can fully utilize the motion thats driven by the stepper motor (lets say positive motion), but no stage movement that is due to the contraction of the o-ring (lets say negative motion). Length of the bolt is sufficient to theoretically support the motion.

Ok thanks. Likewise, when I move the stage to the zero position by looking at the nut through the slot I have very limited movement (less than 5,000 steps) in the negative X and Y axis. The motor spins but the stage doesn’t move any further. I can travel 30,000 steps in the positive X and Y direction. It looks like we have a similar problem.

This is surprising. The ‘mid’ position is with the feet flush with the body as @greenalastair says. There should be equal motion each way from there. It sounds as though the bands are not pulling correctly, but it is not something I have a suggested solution for. You have not got it mounted on a flat surface rather than the Pi base? That would physically prevent the feet from going down.

Can you (or @greenalastair) specify exactly what you mean?
I have attached a picture to clarify the problem. It shows the x-axis in maximum “negative” position.
In neutral position, so when the actuator is perfectly parallel to the bottom of the main stage, no plastic
is visible in the “nut insertion hole”.

We get around 41,000 steps in “positive” direction where the actuator is pulled upwards by the screw.
In “negative” direction (which to my understanding is mainly due to orings pulling on the actuator) we only get around 3,000 steps. Hence, our range of motion right now is 6,2 mm. After this, instead of moving the actuator further downwards, the screw with the gear gets pushed out.
Our unit is fully assembled, so including the Pi base.

That is not much down travel. Can you see anything stopping the actuator moving into the feet? Are you able to push the stage further in that direction? If you pull on one of the feet, it should feel held on by the tension on the bands. If there is tension there in the down position, then there must be something jamming the actuator as it comes down. Maybe stringing in the print of the feet?

I’m seeing exactly the same issue, 40k positive and less than 5k negative. To be clear, the motors don’t stall, they continue to spin the gears but the stage doesn’t move. @cfsb618 are you getting motor stall or do they still spin but no stage motion?

Could it be that my bolts are just too short? I couldn’t find hex head bolts so had to use round head bolts plus nuts.

For reference, how many steps is ‘normal’ for the microscope in X and Y? I’m curious how much motion I’m missing out on.

Motors keep spinning. In positive direction we didn’t went further than 40,000 since this should be the maximum distance of travel. We use 25 mm screws and they don’t seem to be to short.

I can feel the tension from the bands. The downwards movement can be forced by hand, it doesn’t seem that there is something in the way.
I decided now to print a new mainstage, new feet and ordered new Viton o-rings (hardness 70 and 75). Hopefully this will solve the issue. I will report here.

Of course, in the meantime I’m willing to try out upcoming suggestions for solving this problem :slight_smile:

@cfsb618 that is strange. If the actuator can be pushed relatively easily and there is tension on the o-ring band then it has to be able to move. This having the same problem in x and y also is odd. When you pull the feet, does the stage then come down as well?

I think I would take the motors off and take the optics module out (or disconnect the camera cable) so that I could hold the body in my hands and turn the large actuator gears and watch what is happening from all sides. That might show up why it stops moving.

Please do keep us posted on your new stage, perhaps I’ll have to do the same. It is curious that we have exactly the same problem!

Yes it does.

That is excatly why this problem leaves me puzzled. From theory everything should work fine, but practicaly it isn’t. The best theory I could come up with is, that the Orings got somehow stretched a bit too far, so they still excert some amount of tension, but not enough to pull down the actuator. It could also be that the printer messed up a bit and printed the flexure not 100% perfectly and thus it doesn’t move nicely.
On this forum another guy used 80 Hardness Orings; we also experienced the same problems as he did pushing the orings in place. I think we lost around 30 orings… Propably it is here were our problems began.

We already disassembled it, but optically we can’t see anything prohibiting acutator movement. Somehow the problem gets more strange the more we examine it.

I will. We’ve already printed out the new stage, this time on another prusa printer (MK3s). The print looks super good, like absolutely no stringing, smooth and flat surfaces everywhere, so this is very promising. Now I’m just waiting for the orings to arrive.

That does sound bad, and could well be the origin of the problem. If the O-rings break then there is either a problem with the O-ring or the way that you are inserting them is putting stress somewhere that it should not. If the insertion is not going well then the O-rings may not be quite in the right place even when they do not break.

A poor print is less likely to be the problem. The pull of the O-rings is pretty strong and I have actuators that work even where some of the flexure hinges in the base have almost been lost and the walls joined together. That was an extreme case caused by a design change that had made the flexures shorter by mistake, coupled with ‘elephant foot’ over extrusion on the first layer.

So the new O-rings came today. All 75 hardness. First I tried ones that have the dimensions 30 x 2.5 mm. They didn’t worked at all and broke. Then I tried the ones with 32.5 x 2.0 mm. They worked perfectly. Easy to plug in and they excerted enough force to pull the stages down. I didn’t measured it with an objective yet, but a rough measurement gave the impression that the microscope can achieve the 1.2 mm range of motion. So I’m very optimistic on this!

1 Like