No SangaStage device was found during port scanning

Hi, New here… I finally got the SangaBoards v0.5.3 (the last piece I was waiting for) in and was very excited to get everything running today with my OFM v7. Unfortunately, I’ve run into a few problems. I made it through a handful but I’m stuck on one rather important error… the motors don’t turn on.

I’ve read through forums and other things but don’t seem to see this exact issue. When I run ‘ofm rescue’ I get 2 “The serial port didn’t close cleanly” warnings, and then the error in red that says "No SangaStage device was found during port scanning.

The Sangaboard has two blue lights on. The red lights flash occasionally when you turn on the software on or boot up the Pi, but they don’t stay on (which I think is a good thing).

I installed the SangaBoard extension and upgraded the firmware. It said it was successful. The second in the extension area under system HW,FW, and py, don’t have any information next to them, however.

I’m at a loss. Any help would be amazing! Thank you!

Looks like I posted too soon and I figured it out. Posting the result in case it helps anyone…

When I enabled the serial ports in raspi-config, you want to answer NO to the first question, and then YES to the second question about hardware. I had answered yes to both. simple fix…


Welcome and I am glad that you found the issue, that part is not yet particularly well documented. Have you got any pictures from your build?

Well, I made 3… One for me and my kids, one to give to my girlfriend’s 4th grade class, and one to give to my dad’s 4th grade class. I still need to add the illumination and sangaboards to the gray and gold ones. I thought I’d start and get one operational before moving forward on the other two.

I did get that board issue fixed but quickly ran into two other rather undocumented issues.

The microscope objective I got is too short (wrong parfocal / working distance?) for the place it’s mounted. At one point, I had accidentally printed an older model of the microscope frame and it had a shorter slide holder area that would have likely worked fine, but v7 has a thicker stand that pulls the slide further away from the objective. It is sitting about 19mm away from the slide and I think it needs to be 6mm away. It can’t focus. Most of the forum posts about choosing an objective is a lot of “pick what you’d like” but being a newb here, pick what you’d like often turns into picking the wrong thing… so I’ve ordered 3 new objectives that appear to be the right thing, lets hope! :slight_smile: Parfocal length seems incredibly critical to this project, but is not something listed in the description of most objectives… so it seems to be a bit of a guessing game.

The second issue is that the screws holding the small gear on the Z motor grind into the base of the hole it sits down into and doesn’t spin. Probably an issue on my side, although I haven’t figured out what I did wrong yet.

Overall, this is a pretty awesome project. My son (10yrs) has been in charge of printing all of the 3d parts (which took a long time), and he’s very excited to have them up and running soon!


Very nice, and it would be great to hear how the 4th grade classes use it.

The parfocal distance is specified in the microscope instructions (45mm), but as you say it is not always specified in listings when you are trying to buy an objective. It does sound as though you may have found lenses designed for 35mm instead, which is the other standard. It is relatively simple to alter the optics module to mount 10mm higher up, but it does require a little fiddling - there is a section on the customisations page, but it is not intended for general users. We could automatically build those modules, but we don’t do so currently as we don’t test whether they actually work.

The motor gear screws should sit down inside the gear. The gear needs to go on to the motor shaft as far as possible, until the end of the shaft is almost level with the indent in the top of the gear. This can be quite tight, depending on your printer. The screws then sit into the counterbores, which does need screws with the right diameter heads (designed for DIN7981Z). The render in the instructions represents this, where you can see the screw heads flush with the top of the plastic and the brass shaft coming up to the underside of the screw heads.

Oooo! Im excited to try the customization, mostly because I’m impatient and I don’t want to wait for Friday for my new objectives :slight_smile:

This is my inexperience at play. Some of the forum posts are clearly engineers, and while I have a 15’ dedicated “maker” space in my house and my second full size 3d printer about to arrive, I am an enthusiast at best! I copied “DIN7981Z” and pasted it into McMaster-Carr’s search and I got about 1000 results. Looks like I ordered the wrong ones, which would explain why I was fussing so much trying to get the screws to grab when screwing in the illumination module. The heads are too big to fit into the counterbores (honestly, at the time I chalked that up to a bad design rather than my poor instruction following, lol).

I’m attaching an image of what I ordered and I don’t actually see a difference in the instructions and what I ordered. The bill of materials doesn’t seem to specify head diameter… unless I’m missing something.

Image 2-7-24 at 2.12 PM

I will definitely report back on the 4th grade’s use. I know with science classes in elementary school in the US being infrequent or non-existent, both people in question really want to just make things like this more accessible for the kids in their class. Make science a little less scary and foreign… My dad really wants to get them interacting with computers in ways other than YouTube. They have 1:1 computers in the class but they don’t do much with them. He just introduced TinkerCAD in his class this week, and I think the microscope will be a cool addition. :grinning:

1 Like

If what you ordered is the purple highlight, they are the next size bigger. I see you are in the US, McMaster Carr have a great range of what we need, but the labelling is sometimes different. We specify #2 screws, but McMaster Carr list them by metric thread diameter. #2 are the 2.2 mm ones. They also only have the Philips head, rather than Pozi, but the heads are the same size. We need to put that in the instructions.

Ordered! Thank you. Yeah, I’m in the US. I really appreciate your help with all of this!

I made the customization for 35mm in OpenSCAD and printed it last night. I still can’t get it to focus. I’m definitely seeing some blurry color, which is an improvement! I’ll play around with it more over the next few days. When I try the auto stage option, it runs the X axis alllll the way to the edge and then says “moved 30000,0,0” and saw no movement. but you can see it moving. Y and Z also move when I move them with on screen keys. Anyhow, I haven’t done my research on that issue yet… I really appreciate all of your assistance, you helped me overcome some obstacles very quickly!

Can you post some information or photos of the objective and its markings? That might help figure out what the issue is.

This is what I ordered first, and modified with the 35mm adjustment:

I also have these coming in the mail:

Neither of those listings actually state the parfocal length, but there are a couple more things to check.

Firstly, both objectives are marked 160/0.17. this means they are designed for a ‘tube length’ of 160mm. This needs the standard Openflexure RMS optics module, not the one with ‘infinity’ in the STL name. You also do need to have the 50mm focal length tube lens installed.

Secondly both are 40x. A 40x objective has a working distance to the sample of less than 1mm. In your photo the top of the lens is quite a long way below the sample stage, which does suggest a short par-focal length. With the revised optics module is the lens nearly touching the slide?

Finally, as the working distance is less than 1mm, the sample must face the objective. In you photo you have a slide on the purple microscope which has the label and the sample on the top. This needs to be turned over. The lens will not be able to focus through the slide, it is designed to focus through the 0.17mm thick coverslip. That is the ‘0.17’ marked on the lens.

Then you should be able to focus. The stage mapping looks for motion using a correlation. If the images are not focused this does not work well, so while you may be able to see the image changing, the algorithm cannot measure it clearly. When the focus works, I would expect the mapping to work. Just make sure that you move the stage near to the centre before trying again.

I followed the instructions as best I could when ordering them, the only thing that seems to be unlisted everywhere is the parfocal length, unless I’m ordering very expensive ones.

I printed the optics_picamera_2_rms_f50d13.stl first… but as the picture shows, that has the objective about 3/4" (19mm) away from the sample. Using OpenSCAD and modifying it for 35mm put it really close to the sample, and I noticed it knocking against it during the auto calibration. I read in another post about focusing a 40x objective, that they had to move the optics module down a little bit, and not mount it at the highest height. I will try that this evening.

I recognize that I don’t know what I’m doing, but it really seems that the 35mm optics module is ‘more right’ for the objective I have than it was before.

My newest objective order appears, in the photos, to be a longer objective than what I have now… and I’m hoping that means it’s 45mm. This seems critical and I’m a little annoyed that doesn’t just know what I want! Whats the point of all this AI if it isn’t to sell me more stuff! (jk… but also not)

I did put the sample in upside down. I read that in the other forum thread. In the picture I took it is right side up, but I corrected that early on in the focusing attempt.

I feel like this forum post has diverted from its original purpose… should this conversation be done in a separate post? I don’t want to break any forum rules or expectations.

It Works!! Thank you so much for all of your help! I’m so excited!

It is working with the 35MM optics module.

What I figured out is that the optics module had to be pushed up higher than the allen key can reach through the hole. I had to push it up and tighten it down with some needle nose pliers but then the distance is great.

Tomorrow I get the replacement screws, so I’ll bolt down the Z axis and see if the focus tool works. I focused it by manually spinning the Z gear tonight.