Change color/brightness of the camera and shortcuts


I just realized that my camera in OpenFlexure eV sometimes shows black/white and sometimes color image. I would like to control and understand why this happens.

Another issue(should I open a separate topic?): I was wondering if exists an overview of shortcuts. Accidently I realized that the arrow buttons of the keyboard control the X and Y axes. Is there a shortkey to control the Z axe, too? And when I am opening the GPU Preview its so big that I can’t see(and control) the Openflexure software anymore. Therefore I have to restart linux… Is there a shortkey for disabling the GPU preview?

I hope you can help me guys :slight_smile:


I think page up and page down do z/focus. So does the scroll wheel of the mouse which.

Not sure on the others @jc2450 is the fountain of all knowledge when it comes to eV.

@j.stirling Thanks! Page Up/Down do the z/focus

@jc2450 Can you answer my questions:

  • My Picamera in Openflexure eV is currently providing black/white images only, do you know how to change that to color again?
  • is there a shortkey for disabling the GPU preview?

Thanks and cheers!

Hey, that is unusual. Have you run the lens shading calibration? If it’s a software issue, it’ll be something in the camera settings. You could also try backing up and removing the current settings file to reset the camera settings. If that doesn’t help then it may be a hardware issue. @r.w.bowman any thoughts?

There’s no keyboard shortcut for disabling the GPU preview currently. Are you using eV on the microscope Pi, or a separate machine?

Hmm, removing the settings file (config.txt) just results in a disconnected camera because the file isn‘t generated automatically after restart or ofm upgrade.

Yes, I am using it on the microscope pi. The gpu preview just fills out nearly the hole screen and i have no idea how to close it.

I suspect Joel was referring to the settings file at /var/openflexure/settings/microscope_settings.json, not /boot/config.txt. We don’t touch the latter other than enabling the camera in it by default, and setting a bigger GPU memory split.

@jc2450 Is there a guide somewhere to exactly what you mean by removing the settings file. It seems their should be somewhere to point people to?

Hey sorry yes I meant to edit the reply and add the handbook link, then totally forgot. My bad!

The relevant handbook section is Corrupt settings/configuration files

@r.w.bowman @j.stirling @jc2450 : Thank you really much! The deletion of the config/settings JSON’s and a complete recalibration afterwards worked out, I got the colors back :smiley:

1 Like

glad that fixed it :slight_smile: I’m curious - was the image still working, but just in black and white? I’m not sure I’ve seent hat before.

The image was still working, yes. It appears to me black/white but perhaps there were just a lack of color which the complete recalibration fixed. :slight_smile: