Camera error help

Lately I am experiencing several errors with the camera. I have a new built microscope, with a new raspberry pi 4 and original raspberry pi camera. Running vcgencmd get camera shows supported=1 detected=1 and the command “raspistill -o image.jpg” does show an image and saves it.

However, the openflexure connect software shows “camera disconnected: 05/25/2022” and the log shows a warning: Requested an LST from a non-PicameraStreamer camera". I get the same error with all 3 cameras I tried

My stock answer to intermittent or random camera problems is the cable. Either connectors not fully seated or small cracks in the wires.

Is not intermittent. I changed the cables and the cameras. I can take a picture using the raspistill command but I get the “camera disconnected” error with the OFM connect

1 Like

Now, listen to this! :scream_cat: Is the SD card installation. :bulb: I put the SD card to another microscope and I get the same error. The new built microscope works with the old microscope SD card.
This is puzzling

Maybe less puzzling, raspistill and OFM don’t use the camera in exactly the same way. It could be a library update somewhere that does not break raspistill but does break OFM.
Can you try a third card with a fresh image from the current download (new version in April 2022) at Install the Software ( . Or is that what the new microscope was?

(Edit: Probably not the issue, but for completeness what is the reported current server version number on the old card and the new card)

mmmm. The plot thickens. The new microscope (a delta) cannot read the old SD card now. But is does run with the original new SD card where I have the camera problem. Both cards are running server version 2.10.1

Oh dear. Very random.

I will burn another SD card late after I eat my birthday cake. :).

… just don’t burn the SD card on the cake candles :birthday: :smiley:

1 Like

Quick update because is working now.

I flashed a the 2022-04-20 image on this SD card. I noticed it is a 64Gb and not 32 or less like the my other working microscopes. Using a 64GB SD card requires formatting with the exFAT filesystem. According to Raspberry Pi’s official formatting instructions, Raspberry Pi’s bootloader only has support for reading from FAT16 or FAT32 filesystems. Using a 64GB SD card requires you to reformat the card to FAT32 before doing anything else.


I know, I know…I complain a lot. But good things happen when I use the OFM too!. I hope you dont mind me documenting my mistakes and fixes in this forum. I hope it may help someone as well.

I was able to replicate the problem. I discovered another issue besides the SD card format I mentioned above. I am experimenting with this Arduino shield 28BYJ-48 5V Arduino Uno/Mega Shield – Electreim Electronics
I have not problems powering it via the Raspberry pi USB. However, I think sometimes needs more torque. So I decided to add some external 5V power to it to help pushing the motors. Every time I use the external 5V connected to the shield I get a “camera not detected” error. Unplugging corrects the issue. What is the possible connection between the camera and this shield?

1 Like

Linking back to your original thread on that motor board: Is this like the Sangaboard? - Request Help - OpenFlexure Forum, for anyone who has not seen it.

From that thread, the 5V on the shield going to the motors is connected to the Nano 5V pin, which is connected to the USB 5V. Then back in the Pi, the 5V on the USB is the same as the main board 5V. Although the actual processors run at lower voltages regulated down from the 5V, a Pi seems still to be very susceptible to problems on the main 5V rail.

On the motor board you can isolate the 5V of the Arduino from the board, which should isolate the Pi from your motor 5V supply. The simple way would be to cut-off the 5V pin from the Arduino Nano. That should help. You would need to make sure that any stub left of the pin does not make contact in the socket.

Something like this? It may actually work.

Yes, that is what I was thinking. I find that nano clones are the part that is easy to get and cheap to replace when things go wrong, so I would take the pin off that, rather than try to modify the motor board.

I’m getting the same error. Right now I’m trying with the motor stage completely disconnected but still getting no camera signal.

I have a 64GB SD card, so I flashed it to Fat32 as mentioned here but the problem persists.

EDIT: Replaced my camera module and this one is working. I guess that might have been the issue.