"Camera disconnected"

I just assembled my OFM v7 high resolution. Instead of an image, I just get “camera disconnected.” I looked through the 2020 thread about the issue and tried the solutions there, to no avail. I have tried a different cable and camera (both of which work on a different Pi), no luck. I connected my microscope camera to the other Pi and it worked on that one. Everything is up to date and the microscope system appears to work other than the camera. Any ideas? Is it possible my Pi is faulty? I don’t have another Pi 4 to try.

That sounds like a frustrating experience. You have tried all of the obvious things there, the remaining options are less likely but possible.

When you tried the camera and cable on the other Pi, was that running the Openflexure server? If not, have you got a spare SD card to try the Openflexure software on that Pi? It does not need to be physically connected to a microscope or to have a motor controller connected. If that works it sounds as though it is an issue with the Pi4 in your microscope.

If the camera does not work with the Openflexure software on the other Pi, that sounds like a camera or cable issue specific to the way the microscope uses the camera. Openflexure uses a few more things than the standard camera preview and capture on a Pi. It does need to be an actual Raspberry Pi camera V2.1. Other camera boards, even if they use the same Sony camera module, are unlikely to work.

Good luck.

The other Pi is considerably older, a 3 of some kind. I have another 4 on the way to try next.

Do you happen to have a link to a camera that has worked for you (preferably available in the US)? This is the one I’m trying to use: https://www.amazon.com/gp/product/B085HLP8FN/

The Pi 3B or 3B+ are fine for general microscope operation even though they are quite old now.

The link you give for the camera seems to be for two versions, but the words and pictures don’t appear to match. Have you got the one that says Pi camera V2.1 on the circuit board, or the one in the Arducam box? The Pi camera should work in the microscope, the other one may well not.

A lot of maker shops are begining to stock only the Raspberry Pi camera module 3, but the V2.1 is still current.

Edit (probably mainly for others reading the thread): I had a look around US sites. RS have good stock of the Camera v2.1 in the US Raspberry Pi - 913-2664 - Raspberry Pi Camera Module V2, 3280x2464 Pixels, 8 Megapixel, 1/4" (6.35mm) Lens - RS . Farnell/CPC have lots in the UK, but Newark, the US part of that family, only seem to list the Camera module 3.

Hmmm, maybe I’ll try with the old Pi next. My new 4 is coming Tuesday, and I don’t want to wait that long. :joy: This is all meant to be a gift for my wife, who is a veterinary technician and loves microscopy.

Oh, and I have the camera that says Raspberry Pi Camera V2.1.

1 Like

Sooooo without admitting anything, I’m just going to point out that the ribbon cable ports for the camera and for the display output are exactly the same size and shape. :roll_eyes:

1 Like