Just tried to download the python client but it looks like there’s a version conflict. Any suggestions?
/etc/poetry/lib/poetry/_vendor/py2.7/subprocess32.py:149: RuntimeWarning: The _p
osixsubprocess module is not being used. Child process reliability may suffer if
your program uses threads.
"program uses threads.", RuntimeWarning)
The currently activated Python version 2.7.16 is not supported by the project (^3.6).
Trying to find and use a compatible version.
Using python3 (3.7.3)
Creating virtualenv openflexure-microscope-client-FiS6qrJl-py3.7 in
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
NameError: name 'PosixPath' is not defined
Installing dependencies from lock file
The current project's Python requirement (2.7.16) is not compatible with some of the required
packages Python requirement:
- pytest requires Python >=3.5
Because no versions of pytest match >=5.4,<5.4.3 || >5.4.3,<6.0
and pytest (5.4.3) requires Python >=3.5, pytest is forbidden.
So, because openflexure-microscope-client depends on pytest (^5.4), version solving failed.