Network error with HQ camera, is it supported?

Hello all,
we have tried to use a HQ camera but the openflexure software gives a “netwok error” and does not detect the camera. However, it works perfectly with raspistill called from a shell window. The library picameraX library apparently supports the HQ camera and some people in this forum are playing with it.
Any information will be much appreciated. Best regards!

I don’t use the HQ camera, but as you say others on the forum have used it with the Openflexure software.

In general problems on the Pi camera often come down to the connection. It is possible for a camera to work with raspistill, but not actually have all of the wires connected. So the first thing I would suggest is simply to try reseating the cable at both ends. Preferably try a new cable as well as the wires can crack in the cable which is really hard to spot.

Thankyou for your reply,
we just been testing three different cables and reseating them, none of them worked.

I can see from the source code that the picameraX library is being used for camera access. As far as I can see, it has not been updated in about a year. And it has functions like “revision” that return the sensor of the camera, and can only be ov5647 (v1) or imx219 (v2), but not the imx477 of the HQ camera. Furthermore, there are data structures such as SENSOR_MODES with sensor-specific parameters, only for v1 or v2 cameras.
I will try to play with the library and the HQ camera, but I am sadly assuming that the openflexure software does not work with it. yet.

1 Like

The switch to picamerax seems to have been this commit Switch to picamerax (54c342bb) · Commits · OpenFlexure / openflexure-microscope-server · GitLab ‘11 months ago’. That is about the same time as the thread Support for HQ Pi camera - General - OpenFlexure Forum where it clearly worked as it is there on the screen in the photos, but that could well have been the server version before the change.

But also this PiCameraX - Pi Camera + Extras - Announcements - OpenFlexure Forum says that picamerax should support the Pi HQ camera.

@CarlosZL did it more recently, it is not clear whether using the Openflexure server.

I attempted to use the OpenFlexure software with the HQ camera but I only got it to work the first time. After that I attempted to reconnect the camera with different cables and all and was not successful. In addition I did not have access to the Sangaboard to control the stepper motors. That’s I ended up writing me own software in python to view samples, take pictures, control stepper motors, and more. That way you don’t have to write raspistill and raspivid commands on the terminal. Also, when using the HQ camera you will need to double check the raspberry pi settings to make sure you are using and taking advantage of all 12MP that the camera offers.

1 Like

Hello all for your help and suggestions. We realized that had a version of the software several months old, when updated to the lastest version, the HQ camera worked fine. We don’t notice any problem with the resolution, colors… everything fine. I guess that the software is getting images at the v2 resolution, but this is ok.
Thanks and regards,

1 Like